Forums

Minecraft.jar

Discussion in 'Other Minecraft Survival Shinanegans' started by PhantomC, Jan 11, 2011.

  1. PhantomC

    PhantomC Member

    Well, I screwed up my original minceraft.jar with a mod that I now cannot remove. Where can I get a new minecraft.jar file?
     
  2. SonicSNES

    SonicSNES Editor / Community Management Staff Member

    You should be able to just delete the minecraft.jar from your .minecraft folder, then run the exe again. It'll redownload.
     
  3. PhantomC

    PhantomC Member

    Ok, thanks, I'll try that :D
     
  4. PhantomC

    PhantomC Member

    Nope, I ran the .exe and it opens up the minecraft window and says updating minecraft. Below, it has a little loading bar that is nearly loaded and it says done loading, but it's stuck like that.
     
  5. SonicSNES

    SonicSNES Editor / Community Management Staff Member

    delete your entire .minecraft folder (except for your saves, if you have any)
     
  6. PhantomC

    PhantomC Member

    I did that and when I tried to log in it just said login failed
     
  7. PhantomC

    PhantomC Member

    Oh wait nvm, forget I even said that, had my password wrong. >.<
     
  8. PhantomC

    PhantomC Member

    Well, it re-downloaded everything, but unfortunately I ended up with the exact same minecraft.jar I had before. :O
     
  9. SonicSNES

    SonicSNES Editor / Community Management Staff Member

    That's pretty much impossible @_o
     
  10. PhantomC

    PhantomC Member

    It also creates another minecraft.jar, which is great but when I put the mod files I want into it, and replace it into my bin folder, minecraft does that stuck loading screen again. :eek:
     
  11. kagato

    kagato Minecraft Classic Admin

    Maybe try reloading the mods one at a time and figure out which one is fuggin' the whole thing up?
     
  12. Atomical_

    Atomical_ New Member

    Do you have Vista? If you do, disable something which backups the files automaticly. Vista has one originally and must be disabled to not make the new one exactly the same as earlier. I don't know the name of the feature, i have a Finnish computer :confused:
     
  13. KelvarianWcd444

    KelvarianWcd444 New Member

    I cant delete the minecraft.jar at all, it just keeps giving me this error when i try:

    The action can't be completed because the file is open in Java(TM) Platform SE binary
    close the file and try again.
    What do i do?
     
  14. PhantomC

    PhantomC Member

    Hmm, maybe try exiting java if it's open in any form? When you do delete minecraft.jar, you need to delete everything in your .minecraft folder except your saves, then open your minecraft client and it should redownload everything.
     
  15. t7seven7t

    t7seven7t Active Member

    Open up task manager and look for anything that says java in the processes tab and end it. (y)
     
  16. theanarchist

    theanarchist Active Member

    If you really can't get out of ot, just restart and then delete it.
    Always works with me :D
     
  17. Manwich

    Manwich Member

    Remember to always delete the META-INF folder in you minecraft.jar, ALWAYS
     
  18. 100shinx

    100shinx New Member

    Yeah it says to me that I can't delete it (all of the .jar files, though) and when I tried to install a mod, when I was deleting that folder, it said it can't because it was being used by something, and nothing was up that used minecraft.jar. It gave me an option to 'BREAK OPERATION' but when I clicked on it, nothing happened. Now how am I suppose to get the 'Too Many Items' mod? Please help!
     
  19. DevinQRC

    DevinQRC New Member

    i deleted my entire .minecraft folder, but when iredownload it and go into the launcher, it says not downloaded at the bottom after i sign in.
     
  20. Jazz007

    Jazz007 Well-Known Member

    :facepalm:

    EDIT: ...What Konflakes said on next page. New thread would be desirable.